• NotAnder

    @whale-av I tried that before with no results, but now I decided to try again and it did work, seems like I made a mistake before. Thank you so much David (and @myQwil)!

    I'll write the steps I took in order to solve it, in case someone that is having this issue finds this thread.

    • First, I located the file pd-gui.tcl in /usr/lib/puredata/tcl
    • Then, I opened the terminal and changed permissions on the file using the command sudo chmod ugo+rw /usr/lib/puredata/tcl/pd-gui.tcl so I could edit it.
    • Opened pd-gui.tcl, and right below option add *PatchWindow*Canvas.background "white" startupFile (line 294) I added:
    option add *PatchWindow*Canvas.background "white" userDefault
    option add *TkFDialog*foreground "black" userDefault
    option add *TkChooseDir*foreground "black" userDefault
    option add *PdWindow*foreground "black" userDefault
    • Saved the file, close puredata and opened it again.

    Now it looks like this:

    Screenshot at 2021-07-21 18-00-27.png

    : )

    posted in technical issues read more
  • NotAnder


    I recently moved from Windows 10 to Linux Mint, and when I installed puredata, it looked like this by default:

    Screenshot at 2021-07-16 19-36-28.png

    When I change from a dark theme to a light theme, applications like GNU Octave and Mozilla Firefox do change, but it's not the case with puredata. I tried this solution with no luck.

    Any ideas on what is causing this issue, and how can I solve it?

    Linux Mint 20.2 x86_64 MATE
    Puredata 0.50.2

    posted in technical issues read more

Internal error.

Oops! Looks like something went wrong!