• cleq75


    I've got a quick question to Maelstroms patch.

    When I hit [stop( once while playing, then [play(, the counter are out of sync, meaning, they don't hit 0 at the same time anymore.

    When I hit [stop( twice before hitting [play( again, the counter are in sync.

    So, for now I fixed it for my needs with a [delay], sending the needed second hit.
    But I would really like to understand what is going on.

    Is it something I'm doing wrong or what?

    Anyway, thanks for the awesome inspiration with the clock solution.


    posted in technical issues read more
  • cleq75

    Hi, don't know if this is still relevant but anyways, there is a way without Logics automation menu.

    Here is what I do:

    (I'm not sure if it is the slickest thing to do, but it works)

    Logic is using it's own "control language" for its own and external vst/au plugIns.
    You will have to translate your midi cc into Logics language.

    In Logics "environment" on the "mixer"-layer simply connect a "monitor" behind the channelstrip (the cable icon in the upper right corner of the channel object) in which your filter plug is located, so that you can see the messages going out of your channel.

    If you now turn a knob (let's say, the cut-off frequency) in your plugIn, you should see a message in the monitor that looks just like a cc-message only that it is marked with an "F" instead of the "cc-icon".

    Now, on the "click&ports"-layer grab the port on which your cc-data is coming in from the "physical input" and connect it to a "transformer". Configure the "transformer" so that it takes the controller you want to use to control the cut-off frequency and changes it into the "fader"-control data you need for the cut-off-parameter in your plugIn. You will have to change the "Channel" and "Data Byte 1".

    The mapping function in the transformer is the way to go, if you want to control more than one parameter in the plugIn.

    Connect the "transformer" output to the "Channel" (alt-click on the output cable icon to connect between layers) and Voilá! When you send the cc to Logic, you should see the parameter change in the plugIn GUI.

    In this patch, the incoming data goes only to the cable and not to the "SUM" output of the "physical input" object. So it doesn't reach the "Sequencer" by default anymore and you won't see any incoming data in the transport bar. (This is due to the hierarchy of Logic in which the "Environment" is a like a shell around the "Sequencer") To Y-split the incoming data, simply patch a "Monitor" as the first object, which will give you multiple outputs. In case you want to control several Channelstrips via the same port.

    This is of course a "fixed" patch, but Logic lets you patch in a way that you can change the destination of the cc-data within Logic (in the environment-menu New->Fader->Specials is the awesome "cable switcher".

    Hope this helps.

    If anyone has a better solution, please let me know.


    (If this is nothing new, please excuse me. I added some explanations in case someone, who doesn't know that much about Logics environment, finds this )

    posted in technical issues read more
Internal error.

Oops! Looks like something went wrong!